This project has moved. For the latest updates, please go here.

ul and ol tag

May 31, 2012 at 5:58 PM

I'm trying to parse this text

<ul><li>prova</li><li>test</li><li>ciccio</li></ul>

I can't view bullet on document

 

 

Coordinator
May 31, 2012 at 7:20 PM

Hi,

I know the version 1.4.1 doesn't work well with ul/ol. I'm preparing the next release, which will come soon.
For the moment, you can download the source code and recompile the library with the latest checkin.
I have tested your html and it works now.

My apologies for the trouble.

Olivier

Jun 4, 2012 at 10:37 AM

Thank you very much!! I'm going to test  source code and I will give you feedback. 

Hallo!

 

Marco

Jun 26, 2012 at 3:29 PM

I still have problems when parsing this html:

<ul><li>test</li></ul>

It renders this document:

  1. test 

I have downloaded last version I have still problem with ul (ol seems word perfectly)

I'm doing reverse engineering and  looking for bug in new code...

thank you...

Coordinator
Jun 26, 2012 at 8:32 PM

sorry but do you have downloaded the latest version from the Release tab or the Source code?

I can't reproduce your bug. Do you insert the converted paragraphs inside an existing document? If so, could you send it me (you can send me a PM via the contact form)?

Jul 2, 2012 at 6:03 PM

 sorry for delay in my answer - and sorry for my english : /

I have downloaded in source code. 

 

Probably the trouble is in my wrapper class, tomorrow i will check better. 

sorry, forgive me for the mistake. 

 

thanks

Apr 17, 2013 at 1:58 PM
onizet wrote:
Hi, I know the version 1.4.1 doesn't work well with ul/ol. I'm preparing the next release, which will come soon.For the moment, you can download the source code and recompile the library with the latest checkin.I have tested your html and it works now.My apologies for the trouble. Olivier
Hi Onizet,

I downloaded latest version from Downloads, but still ul/ol parts are not rendering ??

Thanks
Jul 2, 2013 at 6:18 PM
I too am having problems with the ul/ol tags. When I pass in the following:
"<ol><li>test1</li><li>test2</li></ol><p/><ul><li>test a</li><li>test b</li></ul>"

I am getting:
test1
test2

test a
test b

in the Word document.
Jul 8, 2013 at 12:28 PM
Edited Jul 8, 2013 at 1:00 PM
I have the same problem with ul/ol tags. Vote for this bug.

Tested latest version built from source code. The bug is still present.
Jul 8, 2013 at 4:32 PM
I'm sorry, that was an error in my post-processing code. Everything is ok now.
Coordinator
Jul 8, 2013 at 8:22 PM
ok nice to hear. But I know that part is not still perfect...
Jul 9, 2013 at 2:28 PM
I downloaded the source code and used that. It works fine in the latest source code, just not in the latest stable build.
Oct 11, 2013 at 1:32 PM
I just got the latest code and compiled myself. But I still have issues on ul-tags. In Word 2010 they are not shown als list, but as normal paragraphs. Wordviewer works somehow.

My tags get rendered to:
<w:p><w:pPr><w:spacing w:after="0" /><w:numPr><w:ilvl w:val="0" /><w:numId w:val="0" /></w:numPr></w:pPr><w:r><w:rPr><w:b /></w:rPr><w:t xml:space="preserve">Apples</w:t></w:r></w:p>

Word 2010 instead, saves the following tag:
<w:p><w:pPr><w:pStyle w:val="ListParagraph"/><w:numPr><w:ilvl w:val="0"/><w:numId w:val="0"/></w:numPr></w:pPr><w:r><w:rPr><w:b/></w:rPr><w:t>Apples</w:t></w:r></w:p>

Since there is not that much activity in this project, still anyone out there to solve such issues?
Apr 9, 2014 at 12:19 PM
Edited Apr 9, 2014 at 12:19 PM
hi there,

I downloaded the version 1.4.2 and I still have issues with ol-tags. In Word 2010, the numeration isn't restarted after each block and if I use the same numeration type on different levels, the html converter didn't recognize the difference.

Example 1:
<ol><li>1</li><li>2<ol><li>3</li></ol></li><li>4<ol><li>5<ol><li>6</li><li>7</li></ol></li></ol></li></ol> Example 2:
<ol><li>Asd</li><li>Asd</li><li>Asd<ol style="list-style-type:lower-alpha"><li>Asd</li><li>Asd</li><li>Asd<ol style="list-style-type:lower-roman"> <li>As</li><li>Dasd</li><li>Asd</li><li>oiiuiuiu</li> </ol></li></ol></li><li>Asd</li><li>Ads</li><li>asdsad</li></ol> The conversion result is: RESULT.

Thanks in advance for your help.

Best regards.
Coordinator
Apr 15, 2014 at 10:21 PM
Hi rfeitor,


Yes I'm aware of that bug. It's just not as easy to fix as it sounds.
The lack of good document on OpenXml stuck me :-(
Apr 16, 2014 at 10:59 AM
Edited May 13, 2015 at 10:16 AM
Thanks anyway, hope you find a solution. :)

Edit: this bug has been fixed.
Thanks :)